CVE-2007-1660

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Perl-Compatible Regular Expression (PCRE) library before 7.0 does not properly calculate sizes for unspecified "multiple forms of character class", which triggers a buffer overflow that allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code.

References

http://bugs.gentoo.org/show_bug.cgi?id=198976

http://docs.info.apple.com/article.html?artnum=307179

http://docs.info.apple.com/article.html?artnum=307562

http://lists.apple.com/archives/security-announce/2007/Dec/msg00002.html

http://lists.apple.com/archives/security-announce/2008/Mar/msg00001.html

http://lists.opensuse.org/opensuse-security-announce/2008-01/msg00006.html

http://lists.vmware.com/pipermail/security-announce/2008/000014.html

http://mail.gnome.org/archives/gtk-devel-list/2007-November/msg00022.html

http://secunia.com/advisories/27538

http://secunia.com/advisories/27543

http://secunia.com/advisories/27547

http://secunia.com/advisories/27554

http://secunia.com/advisories/27598

http://secunia.com/advisories/27697

http://secunia.com/advisories/27741

http://secunia.com/advisories/27773

http://secunia.com/advisories/27776

http://secunia.com/advisories/27862

http://secunia.com/advisories/27965

http://secunia.com/advisories/28136

http://secunia.com/advisories/28406

http://secunia.com/advisories/28414

http://secunia.com/advisories/28658

http://secunia.com/advisories/28714

http://secunia.com/advisories/28720

http://secunia.com/advisories/29420

http://secunia.com/advisories/29785

http://secunia.com/advisories/30106

http://secunia.com/advisories/30155

http://secunia.com/advisories/30219

http://secunia.com/advisories/31124

http://security.gentoo.org/glsa/glsa-200711-30.xml

http://security.gentoo.org/glsa/glsa-200801-02.xml

http://security.gentoo.org/glsa/glsa-200801-18.xml

http://security.gentoo.org/glsa/glsa-200801-19.xml

http://security.gentoo.org/glsa/glsa-200805-11.xml

http://securitytracker.com/id?1018895

http://support.avaya.com/elmodocs2/security/ASA-2007-488.htm

http://www.debian.org/security/2007/dsa-1399

http://www.debian.org/security/2008/dsa-1570

http://www.mandriva.com/security/advisories?name=MDKSA-2007:211

http://www.mandriva.com/security/advisories?name=MDKSA-2007:212

http://www.mandriva.com/security/advisories?name=MDKSA-2007:213

http://www.novell.com/linux/security/advisories/2007_25_sr.html

http://www.novell.com/linux/security/advisories/2007_62_pcre.html

http://www.redhat.com/support/errata/RHSA-2007-0967.html

http://www.redhat.com/support/errata/RHSA-2007-0968.html

http://www.redhat.com/support/errata/RHSA-2007-1063.html

http://www.redhat.com/support/errata/RHSA-2007-1065.html

http://www.redhat.com/support/errata/RHSA-2008-0546.html

http://www.securityfocus.com/archive/1/483357/100/0/threaded

http://www.securityfocus.com/archive/1/483579/100/0/threaded

http://www.securityfocus.com/archive/1/490917/100/0/threaded

http://www.securityfocus.com/bid/26346

http://www.us-cert.gov/cas/techalerts/TA07-352A.html

http://www.vupen.com/english/advisories/2007/3725

http://www.vupen.com/english/advisories/2007/3790

http://www.vupen.com/english/advisories/2007/4238

http://www.vupen.com/english/advisories/2008/0924/references

http://www.vupen.com/english/advisories/2008/1234/references

https://bugzilla.redhat.com/show_bug.cgi?id=315881

https://exchange.xforce.ibmcloud.com/vulnerabilities/38273

https://issues.rpath.com/browse/RPL-1738

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10562

https://usn.ubuntu.com/547-1/

Details

Source: MITRE

Published: 2007-11-07

Updated: 2018-10-16

Type: CWE-119

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:pcre:pcre:*:*:*:*:*:*:*:* versions up to 6.9 (inclusive)

Tenable Plugins

View all (33 total)

IDNameProductFamilySeverity
67612Oracle Linux 3 : pcre (ELSA-2007-1063)NessusOracle Linux Local Security Checks
medium
67588Oracle Linux 4 : pcre (ELSA-2007-0968)NessusOracle Linux Local Security Checks
medium
67587Oracle Linux 5 : pcre (ELSA-2007-0967)NessusOracle Linux Local Security Checks
medium
65042Scientific Linux Security Update : pcre on SL4.x, SL3.x i386/x86_64NessusScientific Linux Local Security Checks
medium
60281Scientific Linux Security Update : pcre on SL5.x, SL4.x i386/x86_64NessusScientific Linux Local Security Checks
medium
43659CentOS 5 : pcre (CESA-2007:0967)NessusCentOS Local Security Checks
medium
41187SuSE9 Security Update : PHP4 (YOU Patch Number 12049)NessusSuSE Local Security Checks
high
41170SuSE9 Security Update : Apache 2 (YOU Patch Number 12000)NessusSuSE Local Security Checks
medium
40377VMSA-2008-0007 : Moderate Updated Service Console packages pcre, net-snmp, and OpenPegasusNessusVMware ESX Local Security Checks
critical
37507CentOS 4 : pcre (CESA-2007:0968)NessusCentOS Local Security Checks
medium
37237Mandrake Linux Security Advisory : pcre (MDKSA-2007:211)NessusMandriva Local Security Checks
high
36264CentOS 3 : pcre (CESA-2007:1063)NessusCentOS Local Security Checks
medium
33512RHEL 2.1 : php (RHSA-2008:0546)NessusRed Hat Local Security Checks
critical
32144Debian DSA-1570-1 : kazehakase - variousNessusDebian Local Security Checks
high
31605Mac OS X Multiple Vulnerabilities (Security Update 2008-002)NessusMacOS X Local Security Checks
critical
29878openSUSE 10 Security Update : apache2-mod_php5 (apache2-mod_php5-4810)NessusSuSE Local Security Checks
high
29780SuSE 10 Security Update : PHP5 (ZYPP Patch Number 4808)NessusSuSE Local Security Checks
high
4322Flash Player < 9.0.115.0 / 7.0.73.0 APSB07-20 Multiple VulnerabilitiesNessus Network MonitorWeb Clients
high
29723Mac OS X Multiple Vulnerabilities (Security Update 2007-009)NessusMacOS X Local Security Checks
critical
29547SuSE 10 Security Update : pcre (ZYPP Patch Number 4689)NessusSuSE Local Security Checks
medium
29244openSUSE 10 Security Update : glib2 (glib2-4768)NessusSuSE Local Security Checks
medium
28366RHEL 2.1 : pcre (RHSA-2007:1065)NessusRed Hat Local Security Checks
medium
28365RHEL 3 : pcre (RHSA-2007:1063)NessusRed Hat Local Security Checks
medium
28359Ubuntu 6.06 LTS / 6.10 / 7.04 / 7.10 : pcre3 vulnerabilities (USN-547-1)NessusUbuntu Local Security Checks
high
28319GLSA-200711-30 : PCRE: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
28285openSUSE 10 Security Update : pcre (pcre-4697)NessusSuSE Local Security Checks
medium
28284openSUSE 10 Security Update : pcre (pcre-4696)NessusSuSE Local Security Checks
medium
28283openSUSE 10 Security Update : pcre (pcre-4683)NessusSuSE Local Security Checks
high
27849Mandrake Linux Security Advisory : pcre (MDKSA-2007:212)NessusMandriva Local Security Checks
high
27814FreeBSD : pcre -- arbitrary code execution (bfd6eef4-8c94-11dc-8c55-001c2514716c)NessusFreeBSD Local Security Checks
high
27646RHEL 4 : pcre (RHSA-2007:0968)NessusRed Hat Local Security Checks
medium
27645RHEL 5 : pcre (RHSA-2007:0967)NessusRed Hat Local Security Checks
medium
27629Debian DSA-1399-1 : pcre3 - several vulnerabilitiesNessusDebian Local Security Checks
high