FreeBSD : bmon -- unsafe set-user-ID application (938f357c-16dd-11d9-bc4a-000c41e2cdad)

High Nessus Plugin ID 36976


The remote FreeBSD host is missing a security-related update.


Jon Nistor reported that the FreeBSD port of bmon was installed set-user-ID root, and executes commands using relative paths. This could allow local user to easily obtain root privileges.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 36976

File Name: freebsd_pkg_938f357c16dd11d9bc4a000c41e2cdad.nasl

Version: $Revision: 1.9 $

Type: local

Published: 2009/04/23

Modified: 2014/09/18

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:bmon, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2004/10/05

Vulnerability Publication Date: 2004/05/29