FreeBSD : rsync buffer overflow in server mode (5729b8ed-5d75-11d8-80e3-0020ed76ef5a)

High Nessus Plugin ID 36807


The remote FreeBSD host is missing a security-related update.


When rsync is run in server mode, a buffer overflow could allow a remote attacker to execute arbitrary code with the privileges of the rsync server. Anonymous rsync servers are at the highest risk.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 36807

File Name: freebsd_pkg_5729b8ed5d7511d880e30020ed76ef5a.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2009/04/23

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:rsync, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2004/02/12

Vulnerability Publication Date: 2003/12/04

Exploitable With


Reference Information

CVE: CVE-2003-0962