FreeBSD : mpg123 buffer overflow (15e0e963-02ed-11d9-a209-00061bc2ad93)

High Nessus Plugin ID 36791


The remote FreeBSD host is missing one or more security-related updates.


The mpg123 software version 0.59r contains a buffer overflow vulnerability which may permit the execution of arbitrary code as the owner of the mpg123 process.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 36791

File Name: freebsd_pkg_15e0e96302ed11d9a20900061bc2ad93.nasl

Version: $Revision: 1.8 $

Type: local

Published: 2009/04/23

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:mpg123, p-cpe:/a:freebsd:freebsd:mpg123-esound, p-cpe:/a:freebsd:freebsd:mpg123-nas, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2004/09/14

Vulnerability Publication Date: 2003/08/16

Reference Information

CVE: CVE-2004-0805