CentOS 3 : pcre (CESA-2007:1063)

Medium Nessus Plugin ID 36264

Synopsis

The remote CentOS host is missing one or more security updates.

Description

Updated pcre packages that resolve several security issues are now available for Red Hat Enterprise Linux 3.

This update has been rated as having important security impact by the Red Hat Security Response Team.

PCRE is a Perl-compatible regular expression library.

Flaws were discovered in the way PCRE handles certain malformed regular expressions. If an application linked against PCRE, such as Konqueror, parsed a malicious regular expression, it may have been possible to run arbitrary code as the user running the application.
(CVE-2006-7228, CVE-2007-1660)

Users of PCRE are advised to upgrade to these updated packages, which contain backported patches to resolve these issues.

Red Hat would like to thank Ludwig Nussel for reporting these issues.

Solution

Update the affected pcre packages.

See Also

http://www.nessus.org/u?8b9c66f0

http://www.nessus.org/u?3745f21a

http://www.nessus.org/u?483852fa

Plugin Details

Severity: Medium

ID: 36264

File Name: centos_RHSA-2007-1063.nasl

Version: 1.12

Type: local

Agent: unix

Published: 2009/04/23

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:centos:centos:pcre, p-cpe:/a:centos:centos:pcre-devel, cpe:/o:centos:centos:3

Required KB Items: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2007/11/29

Reference Information

CVE: CVE-2006-7228, CVE-2007-1660

BID: 26462

RHSA: 2007:1063

CWE: 119, 189