openSUSE 10 Security Update : openswan (openswan-6119)

Medium Nessus Plugin ID 36116


The remote openSUSE host is missing a security update.


By sending a specially crafted Dead Peer Detection (DPD) packet remote attackers could crash the pluto IKE daemon (CVE-2009-0790).


Update the affected openswan package.

Plugin Details

Severity: Medium

ID: 36116

File Name: suse_openswan-6119.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2009/04/08

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:openswan, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/03/24

Reference Information

CVE: CVE-2009-0790

CWE: 20