openSUSE 10 Security Update : phpMyAdmin (phpMyAdmin-6133)

High Nessus Plugin ID 36081


The remote openSUSE host is missing a security update.


This update of phpMyAdmin fixes multiple vulnerabilities :

- CVE-2009-1148: directory traversal

- CVE-2009-1149: CRLF injection

- CVE-2009-1150: cross-site scripting

- CVE-2009-1151: static code injection


Update the affected phpMyAdmin package.

Plugin Details

Severity: High

ID: 36081

File Name: suse_phpMyAdmin-6133.nasl

Version: $Revision: 1.10 $

Type: local

Agent: unix

Published: 2009/04/03

Modified: 2016/12/22

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:phpMyAdmin, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/04/01

Exploitable With


Core Impact

Metasploit (PhpMyAdmin Config File Code Injection)

Elliot (Phpmyadmin File Upload)

Reference Information

CVE: CVE-2009-1148, CVE-2009-1149, CVE-2009-1150, CVE-2009-1151

CWE: 20, 22, 79, 94