openSUSE 10 Security Update : libsndfile (libsndfile-6044)

High Nessus Plugin ID 36080


The remote openSUSE host is missing a security update.


Specially crafted CAF files could cause an integer overflow in libsndfile (CVE-2009-0186).


Update the affected libsndfile packages.

Plugin Details

Severity: High

ID: 36080

File Name: suse_libsndfile-6044.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2009/04/03

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libsndfile, p-cpe:/a:novell:opensuse:libsndfile-32bit, p-cpe:/a:novell:opensuse:libsndfile-devel, p-cpe:/a:novell:opensuse:libsndfile-octave, p-cpe:/a:novell:opensuse:libsndfile-progs, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/03/05

Reference Information

CVE: CVE-2009-0186

CWE: 189