openSUSE 10 Security Update : struts (struts-5872)

Medium Nessus Plugin ID 36049


The remote openSUSE host is missing a security update.


Insufficient quoting of parameters allowed attackers to conduct cross site scripting (XSS) attacks (CVE-2008-2025).


Update the affected struts packages.

Plugin Details

Severity: Medium

ID: 36049

File Name: suse_struts-5872.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2009/03/30

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:struts, p-cpe:/a:novell:opensuse:struts-javadoc, p-cpe:/a:novell:opensuse:struts-manual, p-cpe:/a:novell:opensuse:struts-webapps-tomcat5, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2008/12/17

Reference Information

CVE: CVE-2008-2025

CWE: 79