Slackware 12.0 / 12.1 / 12.2 / current : glib2 (SSA:2009-086-02)

Medium Nessus Plugin ID 36038


The remote Slackware host is missing a security update.


New glib2 packages are available for Slackware 12.0, 12.1, 12.2, and
-current to fix overflows that may be security issues.


Update the affected glib2 package.

See Also

Plugin Details

Severity: Medium

ID: 36038

File Name: Slackware_SSA_2009-086-02.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2009/03/30

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:glib2, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:12.0, cpe:/o:slackware:slackware_linux:12.1, cpe:/o:slackware:slackware_linux:12.2

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Patch Publication Date: 2009/03/28

Reference Information

CVE: CVE-2008-4316

SSA: 2009-086-02

CWE: 189