MySQL 6.0 < 6.0.10 XPath Expression DoS

medium Nessus Plugin ID 36020
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by a denial of service vulnerability.

Description

The version of MySQL 6.0 installed on the remote host is earlier than 6.0.10 and thus affected by a denial of service vulnerability.
Specifically, an authenticated user can cause an assertion failure leading to a server crash by calling 'ExtractValue()' or 'UpdateXML()' using an XPath expression employing a scalar expression as a 'FilterExpr'.

Solution

Upgrade to MySQL Community Server version 6.0.10 or later.

See Also

https://bugs.mysql.com/bug.php?id=42495

http://www.nessus.org/u?ecdcaba5

Plugin Details

Severity: Medium

ID: 36020

File Name: mysql_6_0_10.nasl

Version: 1.12

Type: remote

Family: Databases

Published: 3/26/2009

Updated: 11/15/2018

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3.1

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:mysql:mysql:*:*:*:*:*:*:*:*

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Reference Information

CVE: CVE-2009-0819

BID: 33972

Secunia: 34115