openSUSE 10 Security Update : liblcms (liblcms-6049)

High Nessus Plugin ID 36007


The remote openSUSE host is missing a security update.


Specially crafted image files could cause an integer overflow in lcms.
Attackers could potentially exploit that to crash applications using lcms or even execute arbitrary code (CVE-2009-0723, CVE-2009-0581, CVE-2009-0733).


Update the affected liblcms packages.

Plugin Details

Severity: High

ID: 36007

File Name: suse_liblcms-6049.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2009/03/24

Modified: 2016/12/22

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:liblcms, p-cpe:/a:novell:opensuse:liblcms-32bit, p-cpe:/a:novell:opensuse:liblcms-devel, p-cpe:/a:novell:opensuse:liblcms-devel-32bit, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/03/09

Reference Information

CVE: CVE-2009-0581, CVE-2009-0723, CVE-2009-0733

CWE: 119, 189, 399