openSUSE 10 Security Update : imp (imp-6101)

Medium Nessus Plugin ID 36006


The remote openSUSE host is missing a security update.


Version update to IMP 4.1.6 fixes a problem with validating HTTP requests that allowed attackers to delete emails (CVE-2007-6018) and some cross-site-scripting issues (CVE-2009-0930).


Update the affected imp package.

Plugin Details

Severity: Medium

ID: 36006

File Name: suse_imp-6101.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2009/03/24

Modified: 2016/12/22

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:imp, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2009/03/19

Reference Information

CVE: CVE-2007-6018, CVE-2009-0930

CWE: 79, 264