openSUSE 10 Security Update : ghostscript-devel (ghostscript-devel-6065)

high Nessus Plugin ID 36004

Synopsis

The remote openSUSE host is missing a security update.

Description

Integer overflows and missing upper bounds checks in Ghostscript's ICC library potentially allowed attackers to crash Ghostscript or even cause execution of arbitrary code via specially crafted PS or PDF files (CVE-2009-0583, CVE-2009-0584).

Solution

Update the affected ghostscript-devel packages.

Plugin Details

Severity: High

ID: 36004

File Name: suse_ghostscript-devel-6065.nasl

Version: 1.10

Type: local

Agent: unix

Published: 3/24/2009

Updated: 1/14/2021

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:ghostscript-fonts-other, p-cpe:/a:novell:opensuse:ghostscript-fonts-rus, p-cpe:/a:novell:opensuse:ghostscript-fonts-std, p-cpe:/a:novell:opensuse:ghostscript-ijs-devel, p-cpe:/a:novell:opensuse:ghostscript-library, p-cpe:/a:novell:opensuse:ghostscript-omni, p-cpe:/a:novell:opensuse:ghostscript-x11, p-cpe:/a:novell:opensuse:libgimpprint, p-cpe:/a:novell:opensuse:libgimpprint-devel, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 3/12/2009

Reference Information

CVE: CVE-2009-0583, CVE-2009-0584

CWE: 119, 189