FreeBSD : zabbix -- php frontend multiple vulnerabilities (03140526-1250-11de-a964-0030843d3802)

High Nessus Plugin ID 35998


The remote FreeBSD host is missing one or more security-related updates.


Secunia reports :

Some vulnerabilities have been reported in the ZABBIX PHP frontend, which can be exploited by malicious people to conduct cross-site request forgery attacks and malicious users to disclose sensitive information and compromise a vulnerable system.

Input appended to and passed via the 'extlang' parameter to the 'calc_exp2()' function in include/ is not properly sanitised before being used. This can be exploited to inject and execute arbitrary PHP code.

The application allows users to perform certain actions via HTTP requests without performing any validity checks to verify the requests. This can be exploited to e.g. create users by enticing a logged in administrator to visit a malicious web page.

Input passed to the 'srclang' parameter in locales.php (when 'next' is set to a non-NULL value) is not properly verified before being used to include files. This can be exploited to include arbitrary files from local resources via directory traversal attacks and URL-encoded NULL bytes.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 35998

File Name: freebsd_pkg_03140526125011dea9640030843d3802.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2009/03/24

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:zabbix, p-cpe:/a:freebsd:freebsd:zabbix-agent, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2009/03/16

Vulnerability Publication Date: 2009/03/04

Reference Information

Secunia: 34091