FreeBSD : phppgadmin -- directory traversal with register_globals enabled (4ce3c20b-124b-11de-a964-0030843d3802)

Medium Nessus Plugin ID 35937


The remote FreeBSD host is missing a security-related update.


Secunia reports :

Dun has discovered a vulnerability in phpPgAdmin, which can be exploited by malicious people to disclose sensitive information.

Input passed via the '_language' parameter to libraries/ is not properly sanitised before being used to include files. This can be exploited to include arbitrary files from local resources via directory traversal attacks and URL-encoded NULL bytes.


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 35937

File Name: freebsd_pkg_4ce3c20b124b11dea9640030843d3802.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2009/03/17

Modified: 2016/05/09

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:phppgadmin, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/03/16

Vulnerability Publication Date: 2008/12/08

Reference Information

CVE: CVE-2008-5587

BID: 32670

Secunia: 33014

CWE: 22