FreeBSD : codeigniter -- arbitrary script execution in the new Form Validation class (83574d5a-f828-11dd-9fdf-0050568452ac)

High Nessus Plugin ID 35639


The remote FreeBSD host is missing a security-related update.


znirkel reports :

The eval() function in _reset_post_array crashes when posting certain data. By passing in carefully-crafted input data, the eval() function could also execute malicious PHP code.

Note that CodeIgniter applications that either do not use the new Form Validation class or use the old Validation class are not affected by this vulnerability.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 35639

File Name: freebsd_pkg_83574d5af82811dd9fdf0050568452ac.nasl

Version: $Revision: 1.8 $

Type: local

Published: 2009/02/12

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:codeigniter, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2009/02/11

Vulnerability Publication Date: 2008/11/28