openSUSE 10 Security Update : imap (imap-5868)

Medium Nessus Plugin ID 35247


The remote openSUSE host is missing a security update.


Insufficient buffer length checks in the imap client library may crash applications that use the library to print formatted email addresses.
The imap daemon itself is not affected but certain versions of e.g.
the php imap module are (CVE-2008-5514).

The client library could also crash when a rogue server unexpectedly closes the connection (CVE-2008-5006).


Update the affected imap packages.

Plugin Details

Severity: Medium

ID: 35247

File Name: suse_imap-5868.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2008/12/21

Modified: 2016/12/22

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:imap, p-cpe:/a:novell:opensuse:imap-devel, p-cpe:/a:novell:opensuse:imap-lib, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/12/17

Reference Information

CVE: CVE-2008-5006, CVE-2008-5514

CWE: 119, 399