RHEL 2.1 / 3 / 4 : enscript (RHSA-2008:1021)

High Nessus Plugin ID 35180


The remote Red Hat host is missing a security update.


An updated enscript packages that fixes several security issues is now available for Red Hat Enterprise Linux 2.1, 3, and 4.

This update has been rated as having moderate security impact by the Red Hat Security Response Team.

GNU enscript converts ASCII files to PostScript(R) language files and spools the generated output to a specified printer or saves it to a file. Enscript can be extended to handle different output media and includes options for customizing printouts.

Several buffer overflow flaws were found in GNU enscript. An attacker could craft an ASCII file in such a way that it could execute arbitrary commands if the file was opened with enscript with the 'special escapes' option (-e or --escapes) enabled. (CVE-2008-3863, CVE-2008-4306, CVE-2008-5078)

All users of enscript should upgrade to these updated packages, which contain backported patches to correct these issues.


Update the affected enscript package.

See Also





Plugin Details

Severity: High

ID: 35180

File Name: redhat-RHSA-2008-1021.nasl

Version: $Revision: 1.17 $

Type: local

Agent: unix

Published: 2008/12/16

Modified: 2017/01/03

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:enscript, cpe:/o:redhat:enterprise_linux:2.1, cpe:/o:redhat:enterprise_linux:3, cpe:/o:redhat:enterprise_linux:4, cpe:/o:redhat:enterprise_linux:4.7

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Patch Publication Date: 2008/12/15

Reference Information

CVE: CVE-2008-3863, CVE-2008-4306, CVE-2008-5078

OSVDB: 52158, 52159

RHSA: 2008:1021

CWE: 119