GLSA-200812-10 : Archive::Tar: Directory traversal vulnerability

Medium Nessus Plugin ID 35085


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200812-10 (Archive::Tar: Directory traversal vulnerability)

Jonathan Smith of rPath reported that Archive::Tar does not check for '..' in file names.
Impact :

A remote attacker could entice a user or automated system to extract a specially crafted tar archive, overwriting files at arbitrary locations outside of the specified directory.
Workaround :

There is no known workaround at this time.


All Archive::Tar users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=perl-core/Archive-Tar-1.40'

See Also

Plugin Details

Severity: Medium

ID: 35085

File Name: gentoo_GLSA-200812-10.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2008/12/11

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:Archive-Tar, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/12/10

Reference Information

CVE: CVE-2007-4829

BID: 26355

OSVDB: 40410

GLSA: 200812-10

CWE: 22