CVE-2007-4829

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Directory traversal vulnerability in the Archive::Tar Perl module 1.36 and earlier allows user-assisted remote attackers to overwrite arbitrary files via a TAR archive that contains a file whose name is an absolute path or has ".." sequences.

References

http://osvdb.org/40410

http://rt.cpan.org/Public/Bug/Display.html?id=29517

http://rt.cpan.org/Public/Bug/Display.html?id=30380

http://secunia.com/advisories/27539

http://secunia.com/advisories/33116

http://secunia.com/advisories/33314

http://www.gentoo.org/security/en/glsa/glsa-200812-10.xml

http://www.securityfocus.com/bid/26355

http://www.ubuntu.com/usn/usn-700-1

http://www.ubuntu.com/usn/usn-700-2

http://www.vupen.com/english/advisories/2007/3755

https://bugzilla.redhat.com/show_bug.cgi?id=295021

https://exchange.xforce.ibmcloud.com/vulnerabilities/38285

https://issues.rpath.com/browse/RPL-1716

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11658

Details

Source: MITRE

Published: 2007-11-02

Updated: 2018-08-08

Type: CWE-22

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

Tenable Plugins

View all (8 total)

IDNameProductFamilySeverity
68057Oracle Linux 4 / 5 : perl-Archive-Tar (ELSA-2010-0505)NessusOracle Linux Local Security Checks
medium
60811Scientific Linux Security Update : perl-Archive-Tar on SL4.x, SL5.x i386/x86_64NessusScientific Linux Local Security Checks
medium
47871RHEL 4 / 5 : perl-Archive-Tar (RHSA-2010:0505)NessusRed Hat Local Security Checks
medium
47703CentOS 4 / 5 : perl-Archive-Tar (CESA-2010:0505)NessusCentOS Local Security Checks
medium
37888Ubuntu 6.06 LTS / 7.10 / 8.04 LTS / 8.10 : libarchive-tar-perl, perl vulnerabilities (USN-700-1)NessusUbuntu Local Security Checks
medium
37746Ubuntu 8.04 LTS : perl regression (USN-700-2)NessusUbuntu Local Security Checks
medium
36266Fedora 10 : perl-5.10.0-52.fc10 (2008-11736)NessusFedora Local Security Checks
medium
35085GLSA-200812-10 : Archive::Tar: Directory traversal vulnerabilityNessusGentoo Local Security Checks
medium