openSUSE 10 Security Update : gnutls (gnutls-5844)

Medium Nessus Plugin ID 35080


The remote openSUSE host is missing a security update.


gnutls did not properly verify x509 certificate chains. An attacker could exploit that to trick client programs into trusting servers that would normally get rejected (CVE-2008-4989).


Update the affected gnutls packages.

Plugin Details

Severity: Medium

ID: 35080

File Name: suse_gnutls-5844.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2008/12/10

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:gnutls, p-cpe:/a:novell:opensuse:gnutls-32bit, p-cpe:/a:novell:opensuse:gnutls-devel, p-cpe:/a:novell:opensuse:gnutls-devel-32bit, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/12/04

Reference Information

CVE: CVE-2008-4989

CWE: 255