openSUSE 10 Security Update : imlib2 (imlib2-5804)

High Nessus Plugin ID 35005


The remote openSUSE host is missing a security update.


A security problem was fixed in imlib2 where loading a specific XPM file could corrupt memory. (CVE-2008-5187)


Update the affected imlib2 packages.

Plugin Details

Severity: High

ID: 35005

File Name: suse_imlib2-5804.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2008/12/02

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:imlib2, p-cpe:/a:novell:opensuse:imlib2-devel, p-cpe:/a:novell:opensuse:imlib2-filters, p-cpe:/a:novell:opensuse:imlib2-loaders, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/11/21

Reference Information

CVE: CVE-2008-5187

CWE: 119