openSUSE 10 Security Update : valgrind (valgrind-5809)

High Nessus Plugin ID 34989


The remote openSUSE host is missing a security update.


valgrind reads a file .valgrindrc in the current directory. Therefore local users could place such a file a world-writable directory such as /tmp and influence other users' valgrind when it's executed there (CVE-2008-4865).


Update the affected valgrind packages.

Plugin Details

Severity: High

ID: 34989

File Name: suse_valgrind-5809.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2008/12/01

Modified: 2014/06/27

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:valgrind, p-cpe:/a:novell:opensuse:valgrind-devel, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/11/21

Reference Information

CVE: CVE-2008-4865