openSUSE 10 Security Update : rubygem-activerecord (rubygem-activerecord-5817)

High Nessus Plugin ID 34988


The remote openSUSE host is missing a security update.


Missing sanity checks of the :limit and :offset parameters in SQL queries could potentially be exploited to conduct SQL inection attacks (CVE-2008-4094).


Update the affected rubygem-activerecord package.

Plugin Details

Severity: High

ID: 34988

File Name: suse_rubygem-activerecord-5817.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2008/12/01

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:rubygem-activerecord, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/11/21

Reference Information

CVE: CVE-2008-4094

CWE: 89