openSUSE 10 Security Update : rubygem-actionpack (rubygem-actionpack-5816)

Medium Nessus Plugin ID 34987


The remote openSUSE host is missing a security update.


Missing input sanitation in rubygem-actionpack allowed remote attackers to inject arbitrary HTTP headers via specially crafted URLs (CVE-2008-5189).


Update the affected rubygem-actionpack package.

Plugin Details

Severity: Medium

ID: 34987

File Name: suse_rubygem-actionpack-5816.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2008/12/01

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:rubygem-actionpack, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/11/21

Reference Information

CVE: CVE-2008-5189

CWE: 352