openSUSE 10 Security Update : mysql (mysql-5613)

Medium Nessus Plugin ID 34985


The remote openSUSE host is missing a security update.


Empty bit-strings in a query could crash the MySQL server (CVE-2008-3963).

Due to another flaw users could access tables of other users (CVE-2008-4097, CVE-2008-4098).


Update the affected mysql packages.

Plugin Details

Severity: Medium

ID: 34985

File Name: suse_mysql-5613.nasl

Version: $Revision: 1.9 $

Type: local

Agent: unix

Published: 2008/12/01

Modified: 2016/12/22

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Vector: CVSS2#AV:N/AC:H/Au:S/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:mysql, p-cpe:/a:novell:opensuse:mysql-Max, p-cpe:/a:novell:opensuse:mysql-bench, p-cpe:/a:novell:opensuse:mysql-client, p-cpe:/a:novell:opensuse:mysql-debug, p-cpe:/a:novell:opensuse:mysql-devel, p-cpe:/a:novell:opensuse:mysql-shared, p-cpe:/a:novell:opensuse:mysql-shared-32bit, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/09/19

Reference Information

CVE: CVE-2008-3963, CVE-2008-4097, CVE-2008-4098

CWE: 59, 134, 264