Debian DSA-1670-1 : enscript - buffer overflows

high Nessus Plugin ID 34949

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities have been discovered in Enscript, a converter from ASCII text to Postscript, HTML or RTF. The Common Vulnerabilities and Exposures project identifies the following problems :

- CVE-2008-3863 Ulf Harnhammer discovered that a buffer overflow may lead to the execution of arbitrary code.

- CVE-2008-4306 Kees Cook and Tomas Hoger discovered that several buffer overflows may lead to the execution of arbitrary code.

Solution

Upgrade the enscript package.

For the stable distribution (etch), these problems have been fixed in version 1.6.4-11.1.

For the upcoming stable distribution (lenny) and the unstable distribution (sid), these problems have been fixed in version 1.6.4-13.

See Also

https://security-tracker.debian.org/tracker/CVE-2008-3863

https://security-tracker.debian.org/tracker/CVE-2008-4306

https://www.debian.org/security/2008/dsa-1670

Plugin Details

Severity: High

ID: 34949

File Name: debian_DSA-1670.nasl

Version: 1.12

Type: local

Agent: unix

Published: 11/25/2008

Updated: 1/4/2021

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:enscript, cpe:/o:debian:debian_linux:4.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 11/24/2008

Reference Information

CVE: CVE-2008-3863, CVE-2008-4306

DSA: 1670

CWE: 119