openSUSE 10 Security Update : phpMyAdmin (phpMyAdmin-5781)

Medium Nessus Plugin ID 34813


The remote openSUSE host is missing a security update.


This update of phpMyAdmin fixes the following bugs :

- CVE-2008-1149: SQL injection, CSRF attacks using crafted cookies

- CVE-2008-1567: local users can steal session information/credentials

- CVE-2008-1924: in a shared host environment users with CREAT permissions can read arbitrary files

- CVE-2008-3456: cross-site framing attack

- CVE-2008-3457: user-assisted XSS attack


Update the affected phpMyAdmin package.

Plugin Details

Severity: Medium

ID: 34813

File Name: suse_phpMyAdmin-5781.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2008/11/18

Modified: 2016/12/22

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:phpMyAdmin, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2008/11/14

Reference Information

CVE: CVE-2008-1149, CVE-2008-1567, CVE-2008-1924, CVE-2008-3456, CVE-2008-3457

CWE: 59, 79, 89, 200, 352