SuSE 10 Security Update : Apache 2 (ZYPP Patch Number 5767)

Medium Nessus Plugin ID 34779


The remote SuSE 10 host is missing a security-related patch.


Missing sanity checks of FTP URLs allowed cross-site scripting (XSS) attacks via the mod_prody_ftp module. (CVE-2008-2939)

Missing precautions allowed cross-site request forgery (CSRF) via the mod_proxy_balancer interface. (CVE-2007-6420)


Apply ZYPP patch number 5767.

See Also

Plugin Details

Severity: Medium

ID: 34779

File Name: suse_apache2-5767.nasl

Version: $Revision: 1.13 $

Type: local

Agent: unix

Published: 2008/11/16

Modified: 2016/12/22

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2008/11/14

Reference Information

CVE: CVE-2007-6420, CVE-2008-2939

CWE: 79, 352