MySQL Enterprise Server 5.0 < 5.0.70 Privilege Bypass

medium Nessus Plugin ID 34727
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is susceptible to a privilege bypass attack.

Description

The version of MySQL Enterprise Server 5.0 installed on the remote host is earlier than 5.0.70. In such versions, it is possible for a local user to circumvent privileges through the creation of MyISAM tables employing the 'DATA DIRECTORY' and 'INDEX DIRECTORY' options to overwrite existing table files in the application's data directory.

Note that this issue was supposed to have been addressed in version 5.0.60, but the fix was incomplete.

Solution

Upgrade to MySQL Enterprise version 5.0.70 or later.

See Also

http://bugs.mysql.com/bug.php?id=32167

http://dev.mysql.com/doc/refman/5.0/en/news-5-0-70.html

https://www.openwall.com/lists/oss-security/2008/09/09/20

https://www.openwall.com/lists/oss-security/2008/09/16/3

Plugin Details

Severity: Medium

ID: 34727

File Name: mysql_es_5_0_70.nasl

Version: 1.15

Type: remote

Family: Databases

Published: 11/9/2008

Updated: 11/15/2018

Dependencies: mysql_version.nasl, mysql_login.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.5

CVSS v2

Risk Factor: Medium

Base Score: 4.6

Temporal Score: 3.4

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:mysql:mysql:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Reference Information

CVE: CVE-2008-2079, CVE-2008-4098

BID: 29106

CWE: 264, 59