FreeBSD : vlc -- cue processing stack overflow (4b09378e-addb-11dd-a578-0030843d3802)

High Nessus Plugin ID 34723


The remote FreeBSD host is missing one or more security-related updates.


The VLC Team reports :

The VLC media player contains a stack overflow vulnerability while parsing malformed cue files. The vulnerability may be exploited by a (remote) attacker to execute arbitrary code in the context of VLC media player.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 34723

File Name: freebsd_pkg_4b09378eaddb11dda5780030843d3802.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2008/11/09

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:vlc, p-cpe:/a:freebsd:freebsd:vlc-devel, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/11/08

Vulnerability Publication Date: 2008/11/05

Exploitable With

Core Impact

Metasploit (VLC Media Player RealText Subtitle Overflow)

Reference Information

CVE: CVE-2008-5032, CVE-2008-5036

CWE: 119