openSUSE 10 Security Update : libexiv2 (libexiv2-5707)

Medium Nessus Plugin ID 34509


The remote openSUSE host is missing a security update.


This update of libexiv2 solves a denial of service bug that can be triggered by using crafted metadata. (CVE-2008-2696)


Update the affected libexiv2 packages.

Plugin Details

Severity: Medium

ID: 34509

File Name: suse_libexiv2-5707.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2008/10/29

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libexiv2, p-cpe:/a:novell:opensuse:libexiv2-devel, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/10/22

Reference Information

CVE: CVE-2008-2696

CWE: 189