openSUSE 10 Security Update : libsatsolver (libsatsolver-5706)

High Nessus Plugin ID 34486


The remote openSUSE host is missing a security update.


A remotely exploitable code execution vulnerability via shell metachars has been fixed in libzypp.


Update the affected libsatsolver packages.

Plugin Details

Severity: High

ID: 34486

File Name: suse_libsatsolver-5706.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2008/10/24

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libzypp, p-cpe:/a:novell:opensuse:libzypp-devel, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/10/21