openSUSE 10 Security Update : postfix (postfix-5603)

Low Nessus Plugin ID 34240


The remote openSUSE host is missing a security update.


When exectuting external programs postfix didn't close the file descriptor of the epoll system call. This could potentially be exploited to shutdown postfix (CVE-2008-3889).


Update the affected postfix packages.

Plugin Details

Severity: Low

ID: 34240

File Name: suse_postfix-5603.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2008/09/18

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 2.1

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:postfix, p-cpe:/a:novell:opensuse:postfix-devel, p-cpe:/a:novell:opensuse:postfix-mysql, p-cpe:/a:novell:opensuse:postfix-postgresql, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/09/12

Reference Information

CVE: CVE-2008-3889

CWE: 20