FreeBSD : twiki -- Arbitrary code execution in session files (9227dcaf-827f-11dd-9cd7-0050568452ac)

Medium Nessus Plugin ID 34206


The remote FreeBSD host is missing a security-related update.


Th1nk3r reports :

The version of TWiki installed on the remote host allows access to the 'configure' script and fails to sanitize the 'image' parameter of that script of directory traversal sequences before returning the file contents when the 'action' parameter is set to 'image'. An unauthenticated attacker can leverage this issue to view arbitrary files on the remote host subject to the privileges of the web server user id. .


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 34206

File Name: freebsd_pkg_9227dcaf827f11dd9cd70050568452ac.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2008/09/15

Modified: 2013/08/09

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:twiki, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2008/09/14

Vulnerability Publication Date: 2008/08/05

Reference Information

CVE: CVE-2008-3195

CERT: 362012

CWE: 22