openSUSE 10 Security Update : gaim (gaim-5421)

Medium Nessus Plugin ID 34192


The remote openSUSE host is missing a security update.


- specially crafted MSN SLP messages could cause an integer overflow in gaim. Attackers could potentially exploit that to execute arbitrary code (CVE-2008-2927).

Additionally a problem was fixed that prevented gaim clients from connecting to the ICQ network after a server change on July 1st 2008.


Update the affected gaim packages.

Plugin Details

Severity: Medium

ID: 34192

File Name: suse_gaim-5421.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2008/09/12

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:gaim, p-cpe:/a:novell:opensuse:gaim-devel, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/07/11

Reference Information

CVE: CVE-2008-2927

CWE: 189