openSUSE 10 Security Update : git (git-5585)

High Nessus Plugin ID 34153


The remote openSUSE host is missing a security update.


This patch fixes several buffer overflows in some git tools, when repositories contain very long pathnames. (CVE-2008-3546)


Update the affected git packages.

Plugin Details

Severity: High

ID: 34153

File Name: suse_git-5585.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2008/09/10

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:git, p-cpe:/a:novell:opensuse:git-arch, p-cpe:/a:novell:opensuse:git-core, p-cpe:/a:novell:opensuse:git-cvs, p-cpe:/a:novell:opensuse:git-email, p-cpe:/a:novell:opensuse:git-svn, p-cpe:/a:novell:opensuse:gitk, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/09/06

Reference Information

CVE: CVE-2008-3546

CWE: 119