SuSE 10 Security Update : libxslt (ZYPP Patch Number 5457)

High Nessus Plugin ID 34076


The remote SuSE 10 host is missing a security-related patch.


A heap overflow in the RC4 cryptographic routines in libxslt was fixed which could be used by attackers to potentially execute code.


Apply ZYPP patch number 5457.

See Also

Plugin Details

Severity: High

ID: 34076

File Name: suse_libxslt-5457.nasl

Version: $Revision: 1.15 $

Type: local

Agent: unix

Published: 2008/09/03

Modified: 2012/05/17

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2008/07/20

Reference Information

CVE: CVE-2008-2935

CWE: 119