Slackware 11.0 / 12.0 / 12.1 / current : amarok (SSA:2008-241-01)

Low Nessus Plugin ID 34061


The remote Slackware host is missing a security update.


New Amarok packages are available for Slackware 11.0, 12.0, 12.1, and
-current to fix security issues. In addition, new supporting libgpod packages are available for Slackware 11.0 and 12.0, since a newer version of libgpod than shipped with these releases is required to run Amarok version 1.4.10. The Magnatune music library plugin made insecure use of the /tmp directory, allowing malicious local users to overwrite files owned by the user running Amarok through symlink attacks.


Update the affected amarok and / or libgpod packages.

See Also

Plugin Details

Severity: Low

ID: 34061

File Name: Slackware_SSA_2008-241-01.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2008/08/30

Modified: 2015/03/30

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 3.3

Temporal Score: 2.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:N/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:amarok, p-cpe:/a:slackware:slackware_linux:libgpod, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:11.0, cpe:/o:slackware:slackware_linux:12.0, cpe:/o:slackware:slackware_linux:12.1

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/08/29

Reference Information

CVE: CVE-2008-3699

BID: 30662

OSVDB: 47455

SSA: 2008-241-01

CWE: 59