openSUSE 10 Security Update : perl (perl-5443)

Medium Nessus Plugin ID 34040


The remote openSUSE host is missing a security update.


Specially crafted regular expressions could crash perl (CVE-2008-1927).

Additionally problem in the CGI module was fixed that could result in an endless loop if uploads were cancelled.


Update the affected perl packages.

Plugin Details

Severity: Medium

ID: 34040

File Name: suse_perl-5443.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2008/08/24

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:perl, p-cpe:/a:novell:opensuse:perl-32bit, p-cpe:/a:novell:opensuse:perl-base, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/07/11

Reference Information

CVE: CVE-2008-1927

CWE: 399