FreeBSD : openvpn-devel -- arbitrary code execution (c61ca9cb-64c3-11dd-954d-006097bcc5f4)

High Nessus Plugin ID 33857


The remote FreeBSD host is missing a security-related update.


James Yonan reports :

Security Fix - affects non-Windows OpenVPN clients running OpenVPN 2.1-beta14 through 2.1-rc8 (OpenVPN 2.0.x clients are NOT vulnerable nor are any versions of the OpenVPN server vulnerable).

An OpenVPN client connecting to a malicious or compromised server could potentially receive an 'lladdr' or 'iproute' configuration directive from the server which could cause arbitrary code execution on the client. A successful attack requires that (a) the client has agreed to allow the server to push configuration directives to it by including 'pull' or the macro 'client' in its configuration file, (b) the client succesfully authenticates the server, (c) the server is malicious or has been compromised and is under the control of the attacker, and (d) the client is running a non-Windows OS.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 33857

File Name: freebsd_pkg_c61ca9cb64c311dd954d006097bcc5f4.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2008/08/11

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:openvpn-devel, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2008/08/07

Vulnerability Publication Date: 2008/07/31

Reference Information

CVE: CVE-2008-3459

CWE: 16