Slackware 10.1 / 10.2 / 11.0 / 12.0 / 12.1 / current : python (SSA:2008-217-01)

high Nessus Plugin ID 33824
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Slackware host is missing a security update.

Description

New python packages are available for Slackware 10.1, 10.2, 11.0, 12.0, 12.1, and -current to fix security issues.

Solution

Update the affected python, python-demo and / or python-tools packages.

See Also

http://www.nessus.org/u?41912d97

Plugin Details

Severity: High

ID: 33824

File Name: Slackware_SSA_2008-217-01.nasl

Version: 1.19

Type: local

Published: 8/5/2008

Updated: 1/14/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:python, p-cpe:/a:slackware:slackware_linux:python-demo, p-cpe:/a:slackware:slackware_linux:python-tools, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:10.1, cpe:/o:slackware:slackware_linux:10.2, cpe:/o:slackware:slackware_linux:11.0, cpe:/o:slackware:slackware_linux:12.0, cpe:/o:slackware:slackware_linux:12.1

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 8/4/2008

Vulnerability Publication Date: 4/10/2008

Reference Information

CVE: CVE-2008-1679, CVE-2008-1721, CVE-2008-2315, CVE-2008-2316, CVE-2008-3142, CVE-2008-3144

BID: 28715, 30491

SSA: 2008-217-01

CWE: 119, 189