Fedora 8 : pcre-7.3-4.fc8 (2008-6111)

High Nessus Plugin ID 33415


The remote Fedora host is missing a security update.


- Fri Jul 4 2008 Tomas Hoger <thoger at redhat.com> - 7.3-4

- Apply Tavis Ormandy's patch for CVE-2008-2371.

- Tue Feb 12 2008 Tomas Hoger <thoger at redhat.com> - 7.3-3

- Backport patch from upstream pcre 7.6 to address buffer overflow caused by 'a character class containing a very large number of characters with codepoints greater than 255 (in UTF-8 mode)' CVE-2008-0674, #431660

- Try re-enabling make check again.

- Fri Nov 16 2007 Stepan Kasal <skasal at redhat.com> - 7.3-2

- Remove obsolete ``reqs'

- add dist tag

- update BuildRoot

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected pcre package.

See Also



Plugin Details

Severity: High

ID: 33415

File Name: fedora_2008-6111.nasl

Version: $Revision: 1.14 $

Type: local

Agent: unix

Published: 2008/07/08

Modified: 2015/10/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:pcre, cpe:/o:fedoraproject:fedora:8

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2008/07/06

Reference Information

CVE: CVE-2008-2371

FEDORA: 2008-6111

CWE: 119