CVE-2008-2371

HIGH

Description

Heap-based buffer overflow in pcre_compile.c in the Perl-Compatible Regular Expression (PCRE) library 7.7 allows context-dependent attackers to cause a denial of service (crash) or possibly execute arbitrary code via a regular expression that begins with an option and contains multiple branches.

References

http://bugs.gentoo.org/show_bug.cgi?id=228091

http://ftp.gnome.org/pub/GNOME/sources/glib/2.16/glib-2.16.4.changes

http://lists.apple.com/archives/security-announce/2008/Oct/msg00001.html

http://lists.apple.com/archives/security-announce/2009/May/msg00002.html

http://lists.opensuse.org/opensuse-security-announce/2008-07/msg00001.html

http://marc.info/?l=bugtraq&m=124654546101607&w=2

http://marc.info/?l=bugtraq&m=125631037611762&w=2

http://secunia.com/advisories/30916

http://secunia.com/advisories/30944

http://secunia.com/advisories/30945

http://secunia.com/advisories/30958

http://secunia.com/advisories/30961

http://secunia.com/advisories/30967

http://secunia.com/advisories/30972

http://secunia.com/advisories/30990

http://secunia.com/advisories/31200

http://secunia.com/advisories/32222

http://secunia.com/advisories/32454

http://secunia.com/advisories/32746

http://secunia.com/advisories/35074

http://secunia.com/advisories/35650

http://secunia.com/advisories/39300

http://security.gentoo.org/glsa/glsa-200811-05.xml

http://support.apple.com/kb/HT3216

http://support.apple.com/kb/HT3549

http://ubuntu.com/usn/usn-624-2

http://wiki.rpath.com/wiki/Advisories:rPSA-2008-0305

http://www.debian.org/security/2008/dsa-1602

http://www.gentoo.org/security/en/glsa/glsa-200807-03.xml

http://www.mandriva.com/security/advisories?name=MDVSA-2008:147

http://www.mandriva.com/security/advisories?name=MDVSA-2009:023

http://www.securityfocus.com/archive/1/497828/100/0/threaded

http://www.securityfocus.com/bid/30087

http://www.securityfocus.com/bid/31681

http://www.ubuntu.com/usn/usn-624-1

http://www.ubuntu.com/usn/usn-628-1

http://www.us-cert.gov/cas/techalerts/TA09-133A.html

http://www.vupen.com/english/advisories/2008/2005

http://www.vupen.com/english/advisories/2008/2006

http://www.vupen.com/english/advisories/2008/2336

http://www.vupen.com/english/advisories/2008/2780

http://www.vupen.com/english/advisories/2009/1297

http://www.vupen.com/english/advisories/2010/0833

https://www.redhat.com/archives/fedora-package-announce/2008-July/msg00105.html

https://www.redhat.com/archives/fedora-package-announce/2008-July/msg00123.html

Details

Source: MITRE

Published: 2008-07-07

Updated: 2018-10-11

Type: CWE-119

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:pcre:pcre:7.7:*:*:*:*:*:*:*

Tenable Plugins

View all (22 total)

IDNameProductFamilySeverity
4779PHP 5.x < 5.2.7 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high
45473Ubuntu 9.10 : erlang vulnerability (USN-624-2)NessusUbuntu Local Security Checks
high
40101openSUSE Security Update : pcre (pcre-54)NessusSuSE Local Security Checks
high
38744Mac OS X 10.5.x < 10.5.7 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
critical
36245Mandriva Linux Security Advisory : pcre (MDVSA-2008:147)NessusMandriva Local Security Checks
high
35051FreeBSD : php -- multiple vulnerabilities (27d01223-c457-11dd-a721-0030843d3802)NessusFreeBSD Local Security Checks
high
35043PHP 5 < 5.2.7 Multiple VulnerabilitiesNessusCGI abuses
high
34787GLSA-200811-05 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
34374Mac OS X Multiple Vulnerabilities (Security Update 2008-007)NessusMacOS X Local Security Checks
critical
33754Slackware 12.0 / 12.1 / current : pcre (SSA:2008-210-09)NessusSlackware Local Security Checks
high
33575Ubuntu 6.06 LTS / 7.04 / 7.10 / 8.04 LTS : php5 vulnerabilities (USN-628-1)NessusUbuntu Local Security Checks
critical
33504Ubuntu 6.06 LTS / 7.04 / 7.10 / 8.04 LTS : pcre3 vulnerability (USN-624-1)NessusUbuntu Local Security Checks
high
33460GLSA-200807-03 : PCRE: Buffer overflowNessusGentoo Local Security Checks
high
33433openSUSE 10 Security Update : pcre (pcre-5366)NessusSuSE Local Security Checks
high
33415Fedora 8 : pcre-7.3-4.fc8 (2008-6111)NessusFedora Local Security Checks
high
33414Fedora 9 : pcre-7.3-4.fc9 (2008-6110)NessusFedora Local Security Checks
high
33411Fedora 9 : glib2-2.16.4-1.fc9 (2008-6048)NessusFedora Local Security Checks
high
33406Fedora 8 : glib2-2.14.6-2.fc8 (2008-6025)NessusFedora Local Security Checks
high
33403Debian DSA-1602-1 : pcre3 - buffer overflowNessusDebian Local Security Checks
high
5023Mac OS X 10.5 < 10.5.7 Multiple VulnerabilitiesNessus Network MonitorGeneric
critical
801088PHP 5 < 5.2.7 Multiple VulnerabilitiesLog Correlation EngineWeb Servers
high
800792Mac OS X 10.5 < 10.5.7 Multiple VulnerabilitiesLog Correlation EngineOperating System Detection
high