SuSE 10 Security Update : ImageMagick (ZYPP Patch Number 5278)

Medium Nessus Plugin ID 33380


The remote SuSE 10 host is missing a security-related patch.


ImageMagick and GraphicsMagick are affected by two security problems :

- Buffer overflow in the handling of XCF files CVE-2008-1097: Heap buffer overflow in the handling of PCX files. (CVE-2008-1096)


Apply ZYPP patch number 5278.

See Also

Plugin Details

Severity: Medium

ID: 33380

File Name: suse_ImageMagick-5278.nasl

Version: $Revision: 1.13 $

Type: local

Agent: unix

Published: 2008/07/02

Modified: 2016/12/22

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2008/05/26

Reference Information

CVE: CVE-2008-1096, CVE-2008-1097

CWE: 119, 399