FreeBSD : vim -- Vim Shell Command Injection Vulnerabilities (30866e6c-3c6d-11dd-98c9-00163e000016)

High Nessus Plugin ID 33240


The remote FreeBSD host is missing one or more security-related updates.

Description reports :

Improper quoting in some parts of Vim written in the Vim Script can lead to arbitrary code execution upon opening a crafted file.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 33240

File Name: freebsd_pkg_30866e6c3c6d11dd98c900163e000016.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2008/06/24

Modified: 2018/01/12

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:vim, p-cpe:/a:freebsd:freebsd:vim-console, p-cpe:/a:freebsd:freebsd:vim-lite, p-cpe:/a:freebsd:freebsd:vim-ruby, p-cpe:/a:freebsd:freebsd:vim6, p-cpe:/a:freebsd:freebsd:vim6-ruby, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2008/06/21

Vulnerability Publication Date: 2008/06/16

Reference Information

CVE: CVE-2008-2712

CWE: 20