openSUSE 10 Security Update : openwsman (openwsman-5241)

High Nessus Plugin ID 33088


The remote openSUSE host is missing a security update.


This update provides a fix for the included shttpd web-server to patch a buffer overflow vulnerability in the HTTP request parser. This bug can only be exploited by authenticated users to execute arbitrary code with the privileges of the openwsman/shttp daemon. (CVE-2008-2097)


Update the affected openwsman packages.

Plugin Details

Severity: High

ID: 33088

File Name: suse_openwsman-5241.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2008/06/04

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:openwsman, p-cpe:/a:novell:opensuse:openwsman-client, p-cpe:/a:novell:opensuse:openwsman-devel, p-cpe:/a:novell:opensuse:openwsman-server, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/05/16

Reference Information

CVE: CVE-2008-2097

CWE: 119