Slackware 11.0 / 12.0 / 12.1 / current : rdesktop (SSA:2008-148-01)

High Nessus Plugin ID 32446


The remote Slackware host is missing a security update.


New rdesktop packages are available for Slackware 11.0, 12.0, 12.1, and -current to fix a security issue caused by using rdesktop to connect to a malicious or compromised RDP server.


Update the affected rdesktop package.

See Also

Plugin Details

Severity: High

ID: 32446

File Name: Slackware_SSA_2008-148-01.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2008/05/28

Modified: 2015/03/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:rdesktop, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:11.0, cpe:/o:slackware:slackware_linux:12.0, cpe:/o:slackware:slackware_linux:12.1

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/05/27

Reference Information

CVE: CVE-2008-1801

BID: 29097

OSVDB: 44943

SSA: 2008-148-01

CWE: 189