openSUSE 10 Security Update : emacs (emacs-5247)

Medium Nessus Plugin ID 32439


The remote openSUSE host is missing a security update.


Xemacs automatically loaded fast-lock files which allowed local attackers to execute arbitrary code as the user editing the associated files (CVE-2008-2142).


Update the affected emacs packages.

Plugin Details

Severity: Medium

ID: 32439

File Name: suse_emacs-5247.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2008/05/23

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:emacs, p-cpe:/a:novell:opensuse:emacs-el, p-cpe:/a:novell:opensuse:emacs-info, p-cpe:/a:novell:opensuse:emacs-nox, p-cpe:/a:novell:opensuse:emacs-x11, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/05/16

Reference Information

CVE: CVE-2008-2142